Jokainen päivä on tietoturvapäivä

binary

Pilvipalveluihin erikoistunut tietoturvayritys Qualys on julkaissut sudo-ohjelmasta löytämänsä tietoturva-aukon ja haavoittuvuuden, joka on hämmentävän vaarallinen, yksinkertainen ja globaali. Tämä Unix- ja Linux-käyttöjärjestelmistä löydetty merkittävä tietoturva-aukko on ollut vuosia "piilossa näkyvillä" (hiding in plain sight).

 

Unix ja Linux ovat laajasti käytössä internetin palveluissa ja yritysjärjestelmissä, mutta harvinaisia yksityisen ihmisen työpöydällä. Unix ja Linux kohtelevat erilaisia käyttäjiä eri tavoin. Tavallinen työpöydän käyttäjä, työntekijä tai internet-palvelua hyödyntävä saa luoda tiedostoja, poistaa tiedostoja ja hyödyntää palvelimen tai palvelun kapasiteettia sen mukaisesti mitä käyttöjärjestelmä tai palvelu kyseiselle käyttäjälle tai käyttäjäryhmälle sallii.

 

Monet toimenpiteet eivät kuitenkaan ole tavalliselle käyttäjätilille sallittuja ja vaikuttavat kokonaisuudessa palvelimen tai palvelun toimintaan. Tavalliselle työntekijälle tunnistettava asia voisi olla printterin lisääminen tai verkkoyhteyksien asetusten muuttaminen, tai vaikka ohjelmiston asentaminen. Nämä toimenpiteet vaativatkin enemmän oikeuksia kuin mitä tavallisella käyttäjällä on ja tällöin käyttäjän onlainattavaylläpitäjän tai pääkäyttäjän oikeuksia. Unix ja Linux käyttävät tuohon oikeuksien lainaamiseen (privilege escalation) ohjelmaa nimeltä sudo. Jotta käyttäjä voisi näitä oikeuksia lainata, on hänellä oltava tähän oikeus, mikä saavutetaan esim. sudoers-käyttäjäryhmän jäsenyyden kautta. 

 

Nyt löydetyssä tietoturva-aukossa tuosta sudo-ohjelmasta on löytynyt haavoittuvuus, joka mahdollistaa näiden edellä mainittujen oikeuksien lainaamisen ilman että käyttäjällä on tähän oikeutta. Tätä haavoittuvuutta kutsutaan nimellä paikallinen oikeuksien korottaminen tai Local Privilege Escalation (LPE).  On huomionarvoista, että käyttöjärjestelmissä on käyttäjinä myös muita kuin ihmis, mikä helpottaa kyseisen haavoittuvuuden käyttämis pahaan tarkoitukseen sekä palvelun tai palvelimen kaatamiseen eli sammuttamiseen. Löytyneen haavoittuvuuden tekee erityisen hankalaksi ja monimutkaiseksi se, että Unix ja Linux ovat käytössä niin valtavan monissa eri laitteissa ja palveluissa mediapalvelimista globaaleihin palvelimiin ja kuluttajien kotimodeemeihin. 

 

Paikkaus löydettyyn haavoituvuuteen on jo olemassa ja kaikkien Unixien ja Linuxien kanssa työssä tai kotona touhuavien olisi syytä mitä pikimmin päivittää sudo-ohjelma käyttöjärjestelmän julkaisijan ohjeiden mukaisesti. 

 

Myös Apple on saanut tietoturvahuomiota 

 

Eilen illalla asennettavaksi tulleet iOS- ja iPadOS 14.4 -päivitykset tekevät iOS-laitteet entistä turvallisemmaksi. Tässä päivityksessä tukitaan erityisen huomion kohteena olleet kolme merkittävää tietoturvauhkaa ja väärinkäytön mahdollisuutta. Poikkeuksellista tässä tietoturvapäivityksessä on lisäksi se, että Applen mukaan paikatut aukot ovat olleet aktiivisesti hakkereiden käytössä. Apple on aktiivisesti markkinoitu ja laajasti tunnettu turvallisuudestaan ja tietosuojastaan ja nyt Apple painottaakin tämän päivityksen tärkeyttä. 

 

Mikäli olet iPhonen tai iPadin käyttäjä, suosittelemme päivittämään kaikki iOS-laitteesi mahdollisimman pian. Lisäksi kehoitamme kaikkia yritysten tietoturvasta vastaavia henkilöi painottamaan loppukäyttäjille päivityksen tärkeyttä sekä varmistamaan, että päivitys asennetaan jokaiselle käyttäjälle. Tarvittaessa autamme mielellämme, otathan meihin rohkeasti yhteyttä! 

Yhteydenotto